Commit 512b3240 authored by Joeri de Gooijer's avatar Joeri de Gooijer

CMS-11430 Force use of node 8 + npm 6 and use `npm ci`

`npm ci` speeds up installs by using package-lock.json directly.
Note: it does not check the 'engines' property, that is only
done when adding or changing dependencies.
parent acce21bb
This diff is collapsed.
......@@ -8,8 +8,8 @@
"build": "grunt build"
},
"engines": {
"node": ">=8",
"npm": ">=5"
"node": "8",
"npm": "6"
},
"dependencies": {
"@bloomreach/hippo-theme": "3.2.2",
......
......@@ -307,7 +307,7 @@
<goals><goal>exec</goal></goals>
<configuration>
<executable>npm</executable>
<commandlineArgs>install</commandlineArgs>
<commandlineArgs>ci</commandlineArgs>
</configuration>
</execution>
<execution>
......
This diff is collapsed.
......@@ -7,8 +7,8 @@
"build": "grunt build"
},
"engines": {
"node": ">=8",
"npm": ">=5"
"node": "8",
"npm": "6"
},
"dependencies": {
"font-awesome": "4.6.3"
......
......@@ -223,7 +223,7 @@
<goals><goal>exec</goal></goals>
<configuration>
<executable>npm</executable>
<commandlineArgs>install</commandlineArgs>
<commandlineArgs>ci</commandlineArgs>
</configuration>
</execution>
<execution>
......
......@@ -3,8 +3,8 @@
"license": "Apache-2.0",
"private": true,
"engines": {
"node": ">=8",
"npm": ">=5"
"node": "8",
"npm": "6"
},
"dependencies": {
"jstimezonedetect": "1.0.6"
......
......@@ -182,7 +182,7 @@
<goals><goal>exec</goal></goals>
<configuration>
<executable>npm</executable>
<commandlineArgs>install</commandlineArgs>
<commandlineArgs>ci</commandlineArgs>
</configuration>
</execution>
</executions>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment