Commit 7706b583 authored by Mathijs den Burger's avatar Mathijs den Burger

CMS-11091 Reintegrate feature/CMS-11091

parents 4035107b 5ce3cbd7
engine-strict=true
registry=https://maven.onehippo.com/npm-all/
registry=https://registry.npmjs.org
/*
* Copyright 2014-2016 Hippo B.V. (http://www.onehippo.com)
* Copyright 2014-2018 Hippo B.V. (http://www.onehippo.com)
*
* Licensed under the Apache License, Version 2.0 (the "License");
* you may not use this file except in compliance with the License.
......@@ -213,7 +213,7 @@ module.exports = function (grunt) {
// so it can be used in the java code.
expand: true,
nonull: true,
cwd: '<%= build.npmDir %>/hippo-theme/dist/images/',
cwd: '<%= build.npmDir %>/@bloomreach/hippo-theme/dist/images/',
src: ['hippo-icon-sprite.svg'],
dest: '<%= build.images %>/icons/'
},
......
{
"@bloomreach/hippo-theme@3.2.2": {
"licenses": "Apache-2.0",
"repository": "https://code.onehippo.org/cms-community/hippo-frontend-theme",
"licenseFile": "node_modules/@bloomreach/hippo-theme/LICENSE",
"noticeFile": "node_modules/@bloomreach/hippo-theme/NOTICE"
},
"angular-animate@1.4.8": {
"licenses": "MIT",
"repository": "https://github.com/angular/angular.js"
"repository": "https://github.com/angular/angular.js",
"publisher": "Angular Core Team",
"email": "angular-core+npm@google.com",
"licenseFile": "node_modules/angular-animate/README.md"
},
"angular-aria@1.4.8": {
"licenses": "MIT",
"repository": "https://github.com/angular/angular.js"
"repository": "https://github.com/angular/angular.js",
"publisher": "Angular Core Team",
"email": "angular-core+npm@google.com",
"licenseFile": "node_modules/angular-aria/README.md"
},
"angular-chosen-localytics@1.4.0": {
"licenses": "MIT",
"repository": "https://github.com/leocaseiro/angular-chosen",
"publisher": "jr314159",
"licenseFile": "node_modules/angular-chosen-localytics/LICENSE"
},
"angular-tablesort@1.1.1": {
......@@ -19,7 +32,9 @@
},
"angular-ui-bootstrap@0.14.3": {
"licenses": "MIT",
"repository": "https://github.com/angular-ui/bootstrap"
"repository": "https://github.com/angular-ui/bootstrap",
"publisher": "https://github.com/angular-ui/bootstrap/graphs/contributors",
"licenseFile": "node_modules/angular-ui-bootstrap/README.md"
},
"angular-ui-tree@2.11.0": {
"licenses": "MIT",
......@@ -28,28 +43,45 @@
},
"angular@1.4.8": {
"licenses": "MIT",
"repository": "https://github.com/angular/angular.js"
"repository": "https://github.com/angular/angular.js",
"publisher": "Angular Core Team",
"email": "angular-core+npm@google.com",
"licenseFile": "node_modules/angular/README.md"
},
"angular@1.5.7": {
"angular@1.6.1": {
"licenses": "MIT",
"repository": "https://github.com/angular/angular.js",
"publisher": "Angular Core Team",
"email": "angular-core+npm@google.com",
"licenseFile": "node_modules/angular-chosen-localytics/node_modules/angular/LICENSE.md"
},
"blueimp-canvas-to-blob@3.1.0": {
"licenses": "MIT",
"repository": "https://github.com/blueimp/JavaScript-Canvas-to-Blob"
"repository": "https://github.com/blueimp/JavaScript-Canvas-to-Blob",
"publisher": "Sebastian Tschan",
"url": "https://blueimp.net",
"licenseFile": "node_modules/blueimp-canvas-to-blob/README.md"
},
"blueimp-file-upload@9.9.4": {
"licenses": "MIT",
"repository": "https://github.com/blueimp/jQuery-File-Upload"
"repository": "https://github.com/blueimp/jQuery-File-Upload",
"publisher": "Sebastian Tschan",
"url": "https://blueimp.net",
"licenseFile": "node_modules/blueimp-file-upload/README.md"
},
"blueimp-load-image@2.1.0": {
"licenses": "MIT",
"repository": "https://github.com/blueimp/JavaScript-Load-Image"
"repository": "https://github.com/blueimp/JavaScript-Load-Image",
"publisher": "Sebastian Tschan",
"url": "https://blueimp.net",
"licenseFile": "node_modules/blueimp-load-image/README.md"
},
"blueimp-tmpl@3.1.0": {
"licenses": "MIT",
"repository": "https://github.com/blueimp/JavaScript-Templates"
"repository": "https://github.com/blueimp/JavaScript-Templates",
"publisher": "Sebastian Tschan",
"url": "https://blueimp.net",
"licenseFile": "node_modules/blueimp-tmpl/README.md"
},
"bootstrap-sass@3.3.4": {
"licenses": "MIT",
......@@ -59,30 +91,37 @@
"chosen-npm@1.4.2": {
"licenses": "MIT",
"repository": "https://github.com/harvesthq/chosen",
"publisher": "harvest",
"licenseFile": "node_modules/chosen-npm/LICENSE.md"
},
"google-code-prettify@1.0.1": {
"licenses": "UNKNOWN"
},
"hippo-cms-api@": {
"licenses": "Apache-2.0"
},
"hippo-theme@3.1.0-SNAPSHOT": {
"licenses": "MIT*",
"licenseFile": "node_modules/hippo-theme/LICENSE"
"licenses": "Apache*",
"licenseFile": "node_modules/google-code-prettify/COPYING"
},
"jquery@2.2.4": {
"licenses": "MIT",
"repository": "https://github.com/jquery/jquery",
"publisher": "jQuery Foundation and other contributors",
"url": "https://github.com/jquery/jquery/blob/2.2.4/AUTHORS.txt",
"licenseFile": "node_modules/angular-chosen-localytics/node_modules/jquery/LICENSE.txt"
},
"jquery@3.1.1": {
"licenses": "MIT",
"repository": "https://github.com/jquery/jquery",
"publisher": "jQuery Foundation and other contributors",
"url": "https://github.com/jquery/jquery/blob/3.1.1/AUTHORS.txt",
"licenseFile": "node_modules/jquery/LICENSE.txt"
},
"normalize.css@3.0.2": {
"licenses": "MIT",
"repository": "https://github.com/necolas/normalize.css"
"repository": "https://github.com/necolas/normalize.css",
"publisher": "Nicolas Gallagher",
"licenseFile": "node_modules/normalize.css/README.md"
},
"open-sans-fontface@1.4.0": {
"licenses": "Apache License version 2.0",
"repository": "https://github.com/FontFaceKit/open-sans"
"licenses": "Apache*",
"repository": "https://github.com/FontFaceKit/open-sans",
"licenseFile": "node_modules/open-sans-fontface/README.md"
},
"retinajs@2.0.1": {
"licenses": "MIT",
......@@ -94,6 +133,9 @@
"MIT",
"GPL-3.0"
],
"repository": "https://github.com/lcdsantos/jQuery-Selectric"
"repository": "https://github.com/lcdsantos/jQuery-Selectric",
"publisher": "Leonardo Santos",
"email": "leocs.1991@gmail.com",
"licenseFile": "node_modules/selectric/README.md"
}
}
\ No newline at end of file
}
This diff is collapsed.
This diff is collapsed.
......@@ -7,7 +7,12 @@
"start": "grunt watch",
"build": "grunt build"
},
"engines": {
"node": ">=8",
"npm": ">=5"
},
"dependencies": {
"@bloomreach/hippo-theme": "3.2.2",
"angular": "1.4.8",
"angular-animate": "1.4.8",
"angular-aria": "1.4.8",
......@@ -21,7 +26,6 @@
"blueimp-tmpl": "3.1.0",
"bootstrap-sass": "3.3.4",
"google-code-prettify": "1.0.1",
"hippo-theme": "./target/dependency/hippo-theme.tar.gz",
"normalize.css": "3.0.2",
"open-sans-fontface": "1.4.0",
"retinajs": "2.0.1",
......@@ -29,8 +33,8 @@
},
"devDependencies": {
"grunt": "0.4.5",
"grunt-cli": "1.2.0",
"grunt-autoprefixer": "3.0.3",
"grunt-cli": "1.2.0",
"grunt-contrib-clean": "0.6.0",
"grunt-contrib-concat": "0.5.1",
"grunt-contrib-copy": "0.8.2",
......@@ -39,7 +43,7 @@
"grunt-contrib-uglify": "0.10.0",
"grunt-contrib-watch": "0.6.1",
"grunt-newer": "1.1.1",
"grunt-sass": "1.1.0",
"grunt-sass": "2.1.0",
"grunt-shell": "1.1.2",
"grunt-svgmin": "2.0.1",
"grunt-svgstore": "0.5.0",
......
<?xml version="1.0" encoding="UTF-8"?>
<!--
Copyright 2007-2016 Hippo B.V. (http://www.onehippo.com)
Copyright 2007-2018 Hippo B.V. (http://www.onehippo.com)
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
......@@ -54,14 +54,6 @@
<groupId>org.onehippo.cms7</groupId>
<artifactId>hippo-repository-builtin</artifactId>
</dependency>
<dependency>
<groupId>org.onehippo.cms7.frontend</groupId>
<artifactId>hippo-theme</artifactId>
<version>${hippo.frontend.theme.version}</version>
<classifier>distribution</classifier>
<type>tar.gz</type>
<scope>provided</scope>
</dependency>
<!-- FIXME: these versions need to be in sync with the repository dependencies -->
<dependency>
......@@ -302,26 +294,6 @@
</configuration>
</plugin>
<!-- Fetch Hippo-specific npm dependencies using Maven -->
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-dependency-plugin</artifactId>
<version>${maven.plugin.dependency.version}</version>
<executions>
<execution>
<id>fetch-npm-dependencies</id>
<phase>initialize</phase>
<goals><goal>copy-dependencies</goal></goals>
<configuration>
<includeGroupIds>org.onehippo.cms7.frontend</includeGroupIds>
<includeArtifactIds>hippo-theme</includeArtifactIds>
<stripClassifier>true</stripClassifier>
<stripVersion>true</stripVersion>
</configuration>
</execution>
</executions>
</plugin>
<!-- Use NPM to install/build Hippo theme -->
<plugin>
<groupId>org.codehaus.mojo</groupId>
......
/*
* Copyright 2014-2016 Hippo B.V. (http://www.onehippo.com)
* Copyright 2014-2018 Hippo B.V. (http://www.onehippo.com)
*
* Licensed under the Apache License, Version 2.0 (the "License");
* you may not use this file except in compliance with the License.
......@@ -24,8 +24,8 @@
@import "../../../../../../../../node_modules/bootstrap-sass/assets/stylesheets/bootstrap/_variables";
@import "../../../../../../../../node_modules/bootstrap-sass/assets/stylesheets/bootstrap/_mixins";
// Hippo Theme variables and mixins
@import "../../../../../../../../node_modules/hippo-theme/src/styles/_variables";
@import "../../../../../../../../node_modules/hippo-theme/src/styles/_mixins";
@import "../../../../../../../../node_modules/@bloomreach/hippo-theme/src/styles/_variables";
@import "../../../../../../../../node_modules/@bloomreach/hippo-theme/src/styles/_mixins";
// Variable overrides
@import "../../../../../../styling/styles/_variables";
......
/*
* Copyright 2014-2016 Hippo B.V. (http://www.onehippo.com)
* Copyright 2014-2018 Hippo B.V. (http://www.onehippo.com)
*
* Licensed under the Apache License, Version 2.0 (the "License");
* you may not use this file except in compliance with the License.
......@@ -19,8 +19,8 @@
@import "../../../../node_modules/bootstrap-sass/assets/stylesheets/bootstrap/_mixins";
// Hippo Theme variables and mixins
@import "../../../../node_modules/hippo-theme/src/styles/_variables";
@import "../../../../node_modules/hippo-theme/src/styles/_mixins";
@import "../../../../node_modules/@bloomreach/hippo-theme/src/styles/_variables";
@import "../../../../node_modules/@bloomreach/hippo-theme/src/styles/_mixins";
// Variable overrides
@import "_variables";
......
engine-strict=true
registry=https://maven.onehippo.com/npm-all/
registry=https://registry.npmjs.org
{
"font-awesome@4.6.3": {
"licenses": "(OFL-1.1 AND MIT)",
"repository": "https://github.com/FortAwesome/Font-Awesome"
},
"hippo-console-theme@": {
"licenses": "Apache-2.0"
"repository": "https://github.com/FortAwesome/Font-Awesome",
"publisher": "Dave Gandy",
"email": "dave@fontawesome.io",
"url": "http://twitter.com/davegandy",
"licenseFile": "node_modules/font-awesome/README.md"
}
}
\ No newline at end of file
}
This diff is collapsed.
This diff is collapsed.
......@@ -6,6 +6,10 @@
"grunt": "grunt",
"build": "grunt build"
},
"engines": {
"node": ">=8",
"npm": ">=5"
},
"dependencies": {
"font-awesome": "4.6.3"
},
......
engine-strict=true
registry=https://maven.onehippo.com/npm-all/
registry=https://registry.npmjs.org
{
"name": "hippo-cms-engine",
"requires": true,
"lockfileVersion": 1,
"dependencies": {
"jstimezonedetect": {
"version": "1.0.6",
"from": "jstimezonedetect@1.0.6",
"resolved": "https://maven.onehippo.com/content/groups/npm-all/jstimezonedetect/-/jstimezonedetect-1.0.6.tgz"
"resolved": "https://registry.npmjs.org/jstimezonedetect/-/jstimezonedetect-1.0.6.tgz",
"integrity": "sha1-YNMfus2/V69xsGSIfuBA8Vla21I="
}
}
}
......@@ -2,6 +2,10 @@
"name": "hippo-cms-engine",
"license": "Apache-2.0",
"private": true,
"engines": {
"node": ">=8",
"npm": ">=5"
},
"dependencies": {
"jstimezonedetect": "1.0.6"
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment