Commit e603c62a authored by Bert Leunis's avatar Bert Leunis

CMS-11604 Reintegrate feature/CMS-11604 into release/3.2

parents d63a9f2f b62f3521
......@@ -3,5 +3,6 @@
.DS_Store
atlassian-ide-plugin.xml
classes/
node_modules/
target/
/dashboard/node/
/dashboard/node_modules/
......@@ -49,7 +49,6 @@ module.exports = function gruntFunctions(grunt) {
src: [
'jquery/dist/jquery.js',
'angular/angular.js',
'chosen-npm/public/chosen.jquery.js',
'angular-chosen-localytics/dist/angular-chosen.js',
'angular-ui-bootstrap/ui-bootstrap-tpls.js',
'angular-ui-router/release/angular-ui-router.js',
......@@ -57,6 +56,7 @@ module.exports = function gruntFunctions(grunt) {
'angular-sanitize/angular-sanitize.js',
'angular-aria/angular-aria.js',
'angular-animate/angular-animate.js',
'chosen-js/chosen.jquery.js',
'google-code-prettify/src/prettify.js',
],
},
......
This diff is collapsed.
......@@ -11,27 +11,27 @@
"npm": "6"
},
"dependencies": {
"@bloomreach/hippo-theme": "3.2.2",
"angular": "1.4.8",
"angular-animate": "1.4.8",
"angular-aria": "1.4.8",
"angular-chosen-localytics": "1.4.0",
"angular-chosen-localytics": "1.4.3",
"angular-sanitize": "1.4.8",
"angular-tablesort": "1.1.1",
"angular-ui-bootstrap": "0.14.3",
"angular-ui-router": "0.2.15",
"angular-ui-tree": "2.11.0",
"google-code-prettify": "1.0.1",
"@bloomreach/hippo-theme": "3.2.2",
"jquery": "2.1.4"
"jquery": "3.2.1"
},
"devDependencies": {
"angular-mocks": "1.4.8",
"jasmine-jquery": "2.0.5",
"grunt": "0.4.5",
"grunt": "^1.0.3",
"grunt-cli": "1.2.0",
"grunt-contrib-clean": "0.7.0",
"grunt-contrib-copy": "0.8.2",
"grunt-contrib-jshint": "0.12.0",
"jasmine-jquery": "2.0.5",
"load-grunt-tasks": "3.4.0",
"time-grunt": "1.3.0"
}
......
......@@ -50,30 +50,53 @@
<build>
<plugins>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>exec-maven-plugin</artifactId>
<groupId>com.github.eirslett</groupId>
<artifactId>frontend-maven-plugin</artifactId>
<version>${maven.plugin.frontend.version}</version>
<executions>
<execution>
<id>npm-install</id>
<phase>generate-sources</phase>
<goals><goal>exec</goal></goals>
<id>install node and npm</id>
<goals>
<goal>install-node-and-npm</goal>
</goals>
<configuration>
<executable>npm</executable>
<commandlineArgs>ci</commandlineArgs>
<nodeVersion>${nodejs.version}</nodeVersion>
<npmVersion>${npm.version}</npmVersion>
</configuration>
</execution>
<execution>
<id>npm-build</id>
<phase>process-resources</phase>
<goals><goal>exec</goal></goals>
<id>npm ci</id>
<goals>
<goal>npm</goal>
</goals>
<configuration>
<executable>npm</executable>
<commandlineArgs>run build</commandlineArgs>
<arguments>ci</arguments>
</configuration>
</execution>
<execution>
<id>npm run build</id>
<goals>
<goal>npm</goal>
</goals>
<configuration>
<arguments>run build</arguments>
</configuration>
</execution>
</executions>
</plugin>
<plugin>
<artifactId>maven-clean-plugin</artifactId>
<configuration>
<filesets>
<fileset>
<directory>node</directory>
</fileset>
<fileset>
<directory>node_modules</directory>
</fileset>
</filesets>
</configuration>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-war-plugin</artifactId>
......
<%@ page language="java" contentType="text/html; charset=UTF-8" session="false" pageEncoding="UTF-8" %>
<%--
Copyright 2014-2016 Hippo B.V. (http://www.onehippo.com)
Copyright 2014-2018 Hippo B.V. (http://www.onehippo.com)
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
......@@ -26,7 +26,7 @@
</script>
<script src="${pageContext.request.contextPath}/components/jquery/dist/jquery.js?v=${project.version}"></script>
<script src="${pageContext.request.contextPath}/components/angular/angular.js?v=${project.version}"></script>
<script src="${pageContext.request.contextPath}/components/chosen-npm/public/chosen.jquery.js?v=${project.version}"></script>
<script src="${pageContext.request.contextPath}/components/chosen-js/chosen.jquery.js?v=${project.version}"></script>
<script src="${pageContext.request.contextPath}/components/angular-chosen-localytics/dist/angular-chosen.js?v=${project.version}"></script>
<script src="${pageContext.request.contextPath}/components/angular-ui-bootstrap/ui-bootstrap-tpls.js?v=${project.version}"></script>
<script src="${pageContext.request.contextPath}/components/angular-ui-router/release/angular-ui-router.js?v=${project.version}"></script>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment