Commit 735a078c authored by Erdem Karakus's avatar Erdem Karakus

REPO-2104 [Backport 11.2] PDFBox version updated to 2.0.11

(cherry picked from commit 283c2eec)
parent f66d8488
......@@ -91,7 +91,8 @@
<commons-collections.version>3.2.2</commons-collections.version>
<tika.version>1.18</tika.version>
<!-- keep pdfbox version aligned with the version tika-parsers depends on -->
<pdfbox.version>2.0.8</pdfbox.version>
<!-- tika pdfbox dependency version is different than the original pdfbox version, changed by the REPO-2099 -->
<pdfbox.version>2.0.11</pdfbox.version>
<quartz.version>2.2.1</quartz.version>
<json-lib.version>2.4</json-lib.version>
<easymock.version>3.2</easymock.version>
......@@ -355,7 +356,11 @@
<groupId>org.jdom</groupId>
<artifactId>jdom2</artifactId>
</exclusion>
<!-- version of the pdfbox is directly managed by the repository pom -->
<exclusion>
<groupId>org.apache.pdfbox</groupId>
<artifactId>pdfbox</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
......
......@@ -28,6 +28,12 @@
<artifactId>hippo-repository-tika</artifactId>
<dependencies>
<!-- tika project should use the pdfbox version which defined on the parent repository pom -->
<dependency>
<groupId>org.apache.pdfbox</groupId>
<artifactId>pdfbox</artifactId>
<version>${pdfbox.version}</version>
</dependency>
<dependency>
<groupId>org.apache.tika</groupId>
<artifactId>tika-core</artifactId>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment